<!DOCTYPE html>
<!--[if lt IE 7]>      <html class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if IE 7]>         <html class="no-js lt-ie9 lt-ie8"> <![endif]-->
<!--[if IE 8]>         <html class="no-js lt-ie9"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js"> <!--<![endif]-->
    <head>
				<link href='https://fonts.googleapis.com/css?family=Lato:300,400,900,900italic,300italic,400italic' rel='stylesheet' type='text/css'>
        <meta charset="utf-8">
        <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
				<title>Mrs. Mary Elizabeth &quot;Bess&quot; Ross Speer: Celebration of Life Service Saturday, September 26 at 11:00am - Americus Times-Recorder | Americus Times-Recorder</title>

        <meta name="viewport" content="width=device-width, initial-scale=1">

				<link rel="stylesheet" href="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.min.css?1583853197" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.css?1583853197" />
				<link rel="stylesheet" href="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/css/normalize.css?1583853197" />
				<link rel="stylesheet" href="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/css/base.css?1595866026" />
				<link rel="stylesheet" type="text/css" media="screen" href="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/style.css?1597348379" />

        <script src="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/js/vendor/modernizr-2.6.2.min.js?1583853197"></script>

				<link rel="Shortcut Icon" type="image/ico" href="https://www.americustimesrecorder.com/wp-content/themes/2016-americus-mobile-child/media/img/brand/favicon-americustimesrecorder.png">
				<link rel="apple-touch-icon" href="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/images/brand/apple-touch-icon.png" />

				
																
<!-- This site is optimized with the Yoast SEO plugin v12.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://www.americustimesrecorder.com/2020/09/23/mrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Mrs. Mary Elizabeth &quot;Bess&quot; Ross Speer: Celebration of Life Service Saturday, September 26 at 11:00am - Americus Times-Recorder" />
<meta property="og:description" content="Mrs. Mary Elizabeth &#8220;Bess&#8221; Ross Speer, age 92, passed away on Tuesday, April 7, 2020 at Perfect Care.   A private burial and committal service was held on Thursday, April 9, at Oak Grove Cemetery with Dr. Bryan Myers officiating.  Due to the ongoing COVID-19 emergency, the celebration of life service was postponed and is &hellip;" />
<meta property="og:url" content="https://www.americustimesrecorder.com/2020/09/23/mrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am/" />
<meta property="og:site_name" content="Americus Times-Recorder" />
<meta property="article:section" content="Obituaries" />
<meta property="article:published_time" content="2020-09-23T15:48:17-04:00" />
<meta property="og:image" content="https://m.americustimesrecorder.com/wp-content/uploads/sites/43/2020/04/facebook-americustimesrecorder.png" />
<meta property="og:image:secure_url" content="https://m.americustimesrecorder.com/wp-content/uploads/sites/43/2020/04/facebook-americustimesrecorder.png" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="630" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Mrs. Mary Elizabeth &#8220;Bess&#8221; Ross Speer, age 92, passed away on Tuesday, April 7, 2020 at Perfect Care.   A private burial and committal service was held on Thursday, April 9, at Oak Grove Cemetery with Dr. Bryan Myers officiating.  Due to the ongoing COVID-19 emergency, the celebration of life service was postponed and is [&hellip;]" />
<meta name="twitter:title" content="Mrs. Mary Elizabeth &quot;Bess&quot; Ross Speer: Celebration of Life Service Saturday, September 26 at 11:00am - Americus Times-Recorder" />
<meta name="twitter:image" content="https://www.americustimesrecorder.com/wp-content/uploads/sites/43/2020/04/facebook-americustimesrecorder.png" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://m.americustimesrecorder.com/#website","url":"https://m.americustimesrecorder.com/","name":"Americus Times-Recorder","potentialAction":{"@type":"SearchAction","target":"https://m.americustimesrecorder.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://m.americustimesrecorder.com/2020/09/23/mrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am/#webpage","url":"https://m.americustimesrecorder.com/2020/09/23/mrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am/","inLanguage":"en-US","name":"Mrs. Mary Elizabeth &quot;Bess&quot; Ross Speer: Celebration of Life Service Saturday, September 26 at 11:00am - Americus Times-Recorder","isPartOf":{"@id":"https://m.americustimesrecorder.com/#website"},"datePublished":"2020-09-23T15:48:17-04:00","dateModified":"2020-09-23T15:48:17-04:00","author":{"@id":"https://m.americustimesrecorder.com/#/schema/person/c5f8ff7fa42672d8ca99e5a9588515a3"}},{"@type":["Person"],"@id":"https://m.americustimesrecorder.com/#/schema/person/c5f8ff7fa42672d8ca99e5a9588515a3","name":"Nichole Buchanan","image":{"@type":"ImageObject","@id":"https://m.americustimesrecorder.com/#authorlogo","url":"https://secure.gravatar.com/avatar/10b1c686d86de246d684769af51fd213?s=96&d=mm&r=g","caption":"Nichole Buchanan"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.americustimesrecorder.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Americus Times-Recorder &raquo; Mrs. Mary Elizabeth &#8220;Bess&#8221; Ross Speer:   Celebration of Life Service Saturday, September 26 at 11:00am Comments Feed" href="https://m.americustimesrecorder.com/2020/09/23/mrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/m.americustimesrecorder.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.2"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='all-css-0' href='https://m.americustimesrecorder.com/_static/??-eJxljNsKgCAQBX8oWyyKeoi+JU1o8xauUf59EhRBb4c5w8CxMXTS7LMikEQwT7Sg9I5Ki67MpICvshLE/Gvhz3f8rTuEFEEYLzUzKMIUElBMRj3d0Q686XlX87ZqLm7IMP4=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.americustimesrecorder.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.3.6' media='all' />
<link rel='stylesheet' id='m1mw-css'  href='https://www.americustimesrecorder.com/wp-content/plugins/m1miniweather-bni-.0.2.b/css/weather-icons.min.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://m.americustimesrecorder.com/wp-includes/css/admin-bar.min.css?m=1591831625g' type='text/css' media='all' />
<style id='admin-bar-inline-css'>
#wp-admin-bar-my-sites-search.hide-if-no-js {
	display: none;
}
#wp-admin-bar-my-sites-search label[for="my-sites-search-text"] {
	clip: rect(1px, 1px, 1px, 1px);
	position: absolute !important;
	height: 1px;
	width: 1px;
	overflow: hidden;
}
#wp-admin-bar-my-sites-search {
	height: 38px;
}
#wp-admin-bar-my-sites-search .ab-item {
	height: 34px;
}
#wp-admin-bar-my-sites-search input {
	padding: 0 2px;
	width: 95%;
	width: calc( 100% - 4px );
}
	
</style>
<link rel='stylesheet' id='wp-polls-css'  href='https://www.americustimesrecorder.com/wp-content/plugins/wp-polls/polls-css.css?ver=2.75.3' media='all' />
<style id='wp-polls-inline-css'>
.wp-polls .pollbar {
	margin: 1px;
	font-size: 6px;
	line-height: 8px;
	height: 8px;
	background-image: url('https://www.americustimesrecorder.com/wp-content/plugins/wp-polls/images/default/pollbg.gif');
	border: 1px solid #c8c8c8;
}

</style>
<link rel='stylesheet' id='simple-staff-list-css'  href='https://www.americustimesrecorder.com/wp-content/plugins/simple-staff-list/public/css/simple-staff-list-public.css?ver=2.2.0' media='all' />
<link rel='stylesheet' id='widgetopts-styles-css'  href='https://www.americustimesrecorder.com/wp-content/plugins/widget-options/assets/css/widget-options.css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/style.css?ver=5.4.2' media='all' />
<link rel='stylesheet' id='child-style-css'  href='https://www.americustimesrecorder.com/wp-content/themes/2016-americus-mobile-child/style.css?ver=1586869462' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.americustimesrecorder.com/wp-content/mu-plugins/jetpack/css/jetpack.css?ver=8.9.1' media='all' />
<script src='https://m.americustimesrecorder.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script>
jQuery(document).ready( function($) {
	$('#wp-admin-bar-my-sites-search.hide-if-no-js').show();
	$('#wp-admin-bar-my-sites-search input').keyup( function( ) {

		var searchValRegex = new RegExp( $(this).val(), 'i');

		$('#wp-admin-bar-my-sites-list > li.menupop').hide().filter(function() {

			return searchValRegex.test( $(this).find('> a').text() );

		}).show();

	});
});
	
</script>
<script type='text/javascript' src='https://m.americustimesrecorder.com/wp-includes/js/jquery/jquery-migrate.min.js?m=1591831625g'></script>
<link rel='https://api.w.org/' href='https://m.americustimesrecorder.com/wp-json/' />
<link rel='shortlink' href='https://m.americustimesrecorder.com/?p=48705' />
<link rel="alternate" type="application/json+oembed" href="https://m.americustimesrecorder.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.americustimesrecorder.com%2F2020%2F09%2F23%2Fmrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://m.americustimesrecorder.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fm.americustimesrecorder.com%2F2020%2F09%2F23%2Fmrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am%2F&#038;format=xml" />
<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<style type='text/css'>img#wpstats{display:none}</style><script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-66840185-1', 'auto');
  ga('send', 'pageview');
</script>
								<script type="text/javascript">
          var $ = jQuery;
          var adm_dmm_id = '5f3aa709bb23623aed7b2921';
          var adm_dam_id = '5f3aa750da6fa904f9fb88e1';
          var adm_dpm_id = '5f3aa73eda6fa904f9fb88df';
          var loggedin = false;
          window.admiral = window.admiral || function() {(admiral.q = admiral.q || []).push(arguments)};

          function setCookie() {
              window.admiral('after','measure.detected',function(user) {
                  var d = new Date();
                  d.setTime(d.getTime() + (7*24*60*60*1000));
                  var n = d.toUTCString();
                  if (user.subscribed) {
                      document.cookie = "bni_admiral_loggedin=1; expires=" + n + "; path=/";
                      loggedin = true;
                      return;
                  }
                  document.cookie = "bni_admiral_loggedin=0; expires=" + n + "; path=/";
                  window.sessionStorage.setItem('cfS', '0');
              })
          }
          window.onload = setCookie();

          function readCookie(c) {
              var a = document.cookie.split(';');
              for (var i = 0; i < a.length; i++) {
                  var b = a[i].split('=');
                  var d = b[0].trim();
                  if (c === d) {
                      var e = b[1].trim();
                      if (e === "1") {
                          loggedin = true;
                      } else {
                          loggedin = false;
                      }
                  }
              }
              return true;
          }
          window.onload = readCookie('bni_admiral_loggedin');
          window.admiral('after', 'transact.subscribed', function() {
              var x = window.sessionStorage.getItem('cfS');
              if (x === "1") {
                  return;
              }
              window.sessionStorage.setItem('cfS', '1');
              location.reload();
          })

          $(window).load(function() { // These functions get called when everything has loaded
            if (!loggedin) {
              $("#slidebarList").prepend('<li><a href="#" onclick="window.admiral(&quot;show&quot;, &quot;transact.login&quot;,{offerID:&quot;' + adm_dmm_id + ',' + adm_dpm_id + ',' + adm_dam_id + '&quot;});">Log In</a></li>');
            } else {
              $("#slidebarList").prepend('<li><a href="#" onclick="window.admiral(&quot;show&quot;, &quot;transact.manage&quot;);">Manage Account</a></li>');
            }
            //console.log('%c TESTING ADMIRAL V 2.1', 'background: #222; color: #bada55');
          });

          $( document ).ready(function() {
            // Digital Monthly Membership
            $('#adm_dmm').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dmm_id})
            });
            // Digital Annual Membership
            $('#adm_dam').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dam_id})
            });
            // Digital and Print Membership
            $('#adm_dpm').click(function(c) {
              c.preventDefault();
              window.admiral('show','transact.subscribe',{offerID:adm_dpm_id})
            });
          });
				</script>


				<script async src="//js-sec.indexww.com/ht/p/188239-192868292012837.js"></script>
<script id="optimera-ops" src="https://d15kdpgjg3unno.cloudfront.net/oPS.js?cid=57" data-cid="57"></script>



    <script src='https://www.googletagservices.com/tag/js/gpt.js'></script>


<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>


<script>

googletag.cmd.push(function() {
    			FEATUREDGALLERY_AD = googletag.defineSlot('/1613683/AMR-m-300x250-featured_gallery', [300, 250], 'div-gpt-ad-bigblock-featured_gallery').addService(googletag.pubads());
			googletag.defineSlot('/1613683/AMR-m-300x250-instory-third', [[300, 250], [1, 1]], 'div-gpt-ad-instory-third').addService(googletag.pubads());

  if (!loggedin) {
			googletag.defineSlot('/1613683/AMR-m-1x1-2', [1,1], 'div-gpt-ad-extra_one_by_one').addService(googletag.pubads());
			googletag.defineSlot('/1613683/AMR-m-1x1-3', [1,1], 'div-gpt-ad-extra_oop').addService(googletag.pubads());
			googletag.defineSlot('/1613683/AMR-m-1x1-4', [1,1], 'div-gpt-ad-extra_one_by_one_two').addService(googletag.pubads());
  }
    

			googletag.defineSlot('/1613683/AMR-m-320x50-1', [320, 50], 'div-gpt-ad-mobile-leader').addService(googletag.pubads());
			BIGBLOCK_AD_ONE = googletag.defineSlot('/1613683/AMR-m-300x250-1', [300, 250], 'div-gpt-ad-bigblock-1').addService(googletag.pubads());
			BIGBLOCK_AD_TWO = googletag.defineSlot('/1613683/AMR-m-300x250-2', [300, 250], 'div-gpt-ad-bigblock-2').addService(googletag.pubads());
			BIGBLOCK_AD_THREE = googletag.defineSlot('/1613683/AMR-m-300x250-3', [300, 250], 'div-gpt-ad-bigblock-3').addService(googletag.pubads());
			googletag.defineSlot('/1613683/AMR-m-300x250-4', [300, 250], 'div-gpt-ad-bigblock-4').addService(googletag.pubads());
			googletag.defineSlot('/1613683/AMR-m-300x250-5', [300, 250], 'div-gpt-ad-bigblock-5').addService(googletag.pubads());
			googletag.defineSlot('/1613683/AMR-m-300x250-6', [300, 250], 'div-gpt-ad-bigblock-6').addService(googletag.pubads());
			googletag.defineSlot('/1613683/AMR-m-300x250-18', [300, 250], 'div-gpt-ad-bigblock-18').addService(googletag.pubads());
			googletag.defineSlot('/1613683/AMR-m-300x600-1', [[300, 600], [160, 600]], 'div-gpt-ad-halfpage-1').addService(googletag.pubads());
			googletag.defineSlot('/1613683/AMR-m-1x1-duration', [1,1], 'div-gpt-ad-one_by_one_duration').addService(googletag.pubads());
  if (!loggedin) {
			googletag.defineOutOfPageSlot('/1613683/AMR-m-1x1-1', 'div-gpt-ad-screenshift').addService(googletag.pubads());
			googletag.defineSlot('/1613683/AMR-m-320x50-sticky', [[320, 50], [1, 1]], 'div-gpt-ad-mobile-sticky').addService(googletag.pubads());
  }

                  googletag.pubads().setTargeting("catname", [ "obituaries",  ]);
          
          googletag.pubads().setTargeting("pageurl", "/2020/09/23/mrs-mary-elizabeth-bess-ross");
    
    // Lazy Load settings
    googletag.pubads().enableLazyLoad({
      fetchMarginPercent: 2,  // Fetch slots within .02 viewports.
      renderMarginPercent: 1,  // Render slots within .01 viewports.
      mobileScaling: 0  // same value on mobile.
    });

		googletag.pubads().enableSingleRequest();
		//googletag.pubads().collapseEmptyDivs()
    googletag.pubads().disableInitialLoad();
		googletag.enableServices();

});
</script>




<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID:  '26673ab7-6c90-4748-8b4c-71512dcf8ef3', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [
      {
          slotID: 'div-gpt-ad-bigblock-1',
          slotName: '1613683/AMR-300x250-1',
          sizes: [[300, 600], [300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-2',
          slotName: '1613683/AMR-300x250-2',
          sizes: [[300, 600], [300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-3',
					slotName: '1613683/AMR-300x250-3',
					sizes: [[300, 600], [300, 250]]
			},
      {
          slotID: 'div-gpt-ad-bigblock-4',
          slotName: '1613683/AMR-300x250-4',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-bigblock-5',
          slotName: '1613683/AMR-300x250-5',
          sizes: [[300, 250]]
      },
			{
					slotID: 'div-gpt-ad-bigblock-6',
					slotName: '1613683/AMR-300x250-6',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-7',
					slotName: '1613683/AMR-300x250-7',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-8',
					slotName: '1613683/AMR-300x250-8',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-9',
					slotName: '1613683/AMR-300x250-9',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-10',
					slotName: '1613683/AMR-300x250-10',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-11',
					slotName: '1613683/AMR-300x250-11',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-12',
					slotName: '1613683/AMR-300x250-12',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-13',
					slotName: '1613683/AMR-300x250-13',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-14',
					slotName: '1613683/AMR-300x250-14',
					sizes: [[300, 250]]
			},
			{
					slotID: 'div-gpt-ad-bigblock-15',
					slotName: '1613683/AMR-300x250-15',
					sizes: [[300, 250]]
			},
      {
          slotID: 'div-gpt-ad-instory-top',
          slotName: '1613683/AMR-300x250-16',
          sizes: [[300, 250]]
      },
      {
          slotID: 'div-gpt-ad-instory-bottom',
          slotName: '1613683/AMR-300x250-17',
          sizes: [[300, 250]]
      },
      //{
          //slotID: 'div-gpt-ad-bigblock-18',
          //slotName: '1613683/AMR-300x250-18',
          //sizes: [[300, 250]]
      //},
      //{
          //slotID: 'div-gpt-ad-instory-third',
          //slotName: '1613683/AMR-300x250-instory-third',
          //sizes: [[300, 250]]
      //},
      {
          slotID: 'div-gpt-ad-mobile-sticky',
          slotName: '1613683/AMR-320x50-1',
          sizes: [[320, 50], [1, 1]]
      }
     ],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
				 googletag.pubads().refresh();
     });
}); 
</script>


<script>
   var otkjs = otkjs || {};
    /**
     * Add any divs to refresh.
     * 
     * Parameters:
     * 1. Array of divs w/parameter to refresh, can be one or many:
     *  - DIV_ID: The DOM div id of the ad position
     *  - MIN_TIME_IN_VIEW: The amount of time the ad must be 
     *      in view before being eligible to be refreshed, we recommend at least 1.1 seconds
     *  - MIN_TIME_ON_PAGE: The amount of time the ad must be in von the page before refreshing 
     *  - TARGETING: Array of key/value targeting for the ad slot.
     * 
     * NOTE: The ad will on refresh once the parameters are met and the ad is
     * is currently in view.
     * 
     * Function:
     * otkjs.addRefresh(
     * Array[
     *    Array[DIV_ID, MIN_TIME_IN_VIEW, MIN_TIME_ON_PAGE, TARGETING[Array['key', 'value']]
     * ]);
     * 
     * Example - add two ad divs to be refreshed:
     *   otkjs.addRefresh([
     *     ['div-1', 1.1, 30, [['key2', 'value2'], ['refresh', 'true']]],
     *     ['div-2', 1.1, 30, [['key4', 'value4'], ['refresh', 'true']]]
     *   ]);
     */
      var mt_in_view = 1.2
      var mt_on_page = 34

      otkjs.addRefresh([
        //['div-1', mt_in_view, mt_on_page, [['refresh', 'true']]]
        ['div-gpt-ad-extra_one_by_one', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_oop', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-extra_one_by_one_two', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-mobile-leader', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-2', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-3', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-4', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-5', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-bigblock-6', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-halfpage-1', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-screenshift', mt_in_view, mt_on_page, [['refresh', 'true']]],
        ['div-gpt-ad-mobile-sticky', mt_in_view, mt_on_page, [['refresh', 'true']]],
      ]);
  </script>
        <script type="text/javascript">!(function(o,n,t){t=o.createElement(n),o=o.getElementsByTagName(n)[0],t.async=1,t.src="https://gondolagnome.com/v2/0/mtgogOEPjeqWgM-RHhCFIDVoh-IGRVl2wJKqyjNRfsC_XHLyhY1U9uirbynAcRs_KPE1H7eqTOCB-g",o.parentNode.insertBefore(t,o)})(document,"script"),(function(o,n){o[n]=o[n]||function(){(o[n].q=o[n].q||[]).push(arguments)}})(window,"admiral");!(function(n,e,r,t){function o(){if((function o(t){try{return(t=localStorage.getItem("v4ac1eiZr0"))&&0<t.split(",")[4]}catch(n){}return!1})()){var t=n[e].pubads();typeof t.setTargeting===r&&t.setTargeting("admiral-engaged","true")}}(t=n[e]=n[e]||{}).cmd=t.cmd||[],typeof t.pubads===r?o():typeof t.cmd.unshift===r?t.cmd.unshift(o):t.cmd.push(o)})(window,"googletag","function");;;;;</script>

<script async src="https://sync.serverbid.com/ss/2000707.js"></script>


                        <script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script>
        
    </head>
		<body id="articlePage">
        <!--[if lt IE 7]>
            <p class="chromeframe">You are using an <strong>outdated</strong> browser. Please <a href="http://browsehappy.com/">upgrade your browser</a> or <a href="http://www.google.com/chromeframe/?redirect=true">activate Google Chrome Frame</a> to improve your experience.</p>
        <![endif]-->
																<!-- Paste this after your <body> tag. Fill in "ARTICLE_URL" and "CONTENT_ID" --> 
				<script type="text/javascript"> 
				(function() { 
					var ARTICLE_URL = 'https://m.americustimesrecorder.com/2020/09/23/mrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am/'; 
					var CONTENT_ID = ''; // Optional or leave empty 
					document.write( 
						'<scr'+'ipt '+ 
						'src="//survey.g.doubleclick.net/survey?site=_bau5bcobj6swf6thmqzfm5mdw4'+ 
						'&amp;url='+encodeURIComponent(ARTICLE_URL)+ 
						(CONTENT_ID ? '&amp;cid='+encodeURIComponent(CONTENT_ID) : '')+ 
						'&amp;random='+(new Date).getTime()+ 
						'" type="text/javascript">'+'\x3C/scr'+'ipt>'); 
          })(); 

          jQuery(document).ready(function() { // These functions get called on DOM ready
						if (!loggedin) {
							load_402_show_function();
						}
          });
				</script> 
				

				<div class="undertone">

				<div class="mobile-nav sb-slide">
									<div class="sb-toggle-left navbar-left">
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
						<div class="navicon-line"></div>
					</div><!-- /.sb-control-left -->
					<a href="https://m.americustimesrecorder.com">
						<img class="logo" src="https://www.americustimesrecorder.com/wp-content/themes/2016-americus-mobile-child/media/img/brand/logo-white-americustimesrecorder.png" alt="Americus Times-Recorder" />
					</a>
					<div class="search">
						<a href="#" class="expand">expand</a>
						<form method="get" class="searchForm" action="https://m.americustimesrecorder.com/site-search">
							<input type="submit" class="searchButton" value="Go" />
							<input type="text" name="q" class="searchQuery" value="Search Americus Times-Recorder..." onfocus="if(this.value=='Search Americus Times-Recorder...'){this.value='';}" onblur="if(this.value==''){this.value='Search Americus Times-Recorder...';}" />
						</form>
					</div>
				</div>

				<div id="sb-site">
					<!-- Add your site or application content here -->
					<div class="upper_ad">
						<div class="wrapper">
							<div class="ad">
								<div class="ad720x90">Ad Spot</div>
							</div>
						</div>
					</div>
					<div class="sup_nav">
						<div class="wrapper">
							<ul id="supNav">
	<li class=""><a href="https://m.americustimesrecorder.com/services/about-us/">About Us</a></li>
  <li class="subscribe"><a href="https://m.americustimesrecorder.com/subscriptions/">Subscribe</a></li>
	<li class=""><a href="https://m.americustimesrecorder.com/submit/">Submit</a></li>
	<li class="public-notices"><a href="https://marketplace.americustimesrecorder.com/AdHunter/americus/Home/Search?majorClass=2600">Public Notices</a></li>
	<li><a href="https://subscriptions.americustimesrecorder.com/CircStore/Account/Login?vendor=DirXion&prodId=ATR" rel="bookmark">E-Edition</a></li>
</ul>							<p class="date">
								September 23, 2020							</p>
							<div class="clearfix"></div>
						</div>
					</div>
					<div class="wrapper">
						<header>
							<nav id="navbar">
								<ul id="mainNav">
	<li class="home "><a href="https://m.americustimesrecorder.com">Home</a></li>
	<li class="news "><a href="https://m.americustimesrecorder.com/category/news/">Local News</a></li>
	<li class="sports"><a href="https://m.americustimesrecorder.com/category/sports/">Local Sports</a></li>
	<li class="opinion"><a href="https://m.americustimesrecorder.com/category/opinion/">Opinion</a></li>
	<li class="obits"><a href="https://m.americustimesrecorder.com/category/obituaries/">Obits</a></li>
	<li class="lifestyles"><a href="https://m.americustimesrecorder.com/category/lifestyles/">Lifestyles</a></li>
	<li class="religion"><a href="https://m.americustimesrecorder.com/category/religion/">Religion</a></li>
	<li class="classifieds"><a href="https://marketplace.americustimesrecorder.com/AdHunter/americus">Classifieds</a></li>
</ul>
							</nav>
							<div class="clearfix"></div>
						</header>

						<div id="content">
							<div id="notifications">
								






								


								
								
							</div>


<div class="one_by_one_group">
<!-- one_by_one_wall-->
<div id='div-gpt-ad-one_by_one_wall'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_wall'); });
  </script>
</div>	<!-- SCREENSHIFT -->
<div id='div-gpt-ad-screenshift'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-screenshift'); });
  </script>
</div></div>

	
							<div class="ad first">
								<!-- 320x50_mobile_leader -->
<div id='div-gpt-ad-mobile-leader'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-leader'); });
  </script>
</div>							</div>



							<div class="main_column">
								<div class="story">
									
									
                      <div class="prev_next_article">
  <!-- v 1.61 -->
          <div class="prev_article">
        <div class="padding">
          <a href="https://m.americustimesrecorder.com/2020/09/21/reverend-john-paul-dent-september-18-2020/" class="arrow left button">
            <svg width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            45.63,75.8 0.375,38.087 45.63,0.375 "/>
            </svg>  
          </a>
        </div>
      </div>
    
                      <div class="next_article">
        <div class="padding">
          <div class="label">You Might Like</div>
                    <h4> <a href="https://m.americustimesrecorder.com/2020/09/21/reverend-john-paul-dent-september-18-2020/">Reverend John Paul Dent: September 18, 2020</a> </h4>
          <a href="https://m.americustimesrecorder.com/2020/09/21/reverend-john-paul-dent-september-18-2020/" class="arrow right button">
            <svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" width="30px" height="30px" viewBox="0 0 50 80" xml:space="preserve">
              <polyline fill="none" stroke="#000000" stroke-width="1" stroke-linecap="round" stroke-linejoin="round" points="
            0.375,0.375 45.63,38.087 0.375,75.8 "/>
            </svg>
          </a>
        </div>
      </div>
        <div class="clearfix"></div>
  </div>


                    <div class="gallery_group">
      <div id="story_photo_group">
        
                                    

              </div>
    </div>
		
									<div id="leftRail" class="">
																			</div><!-- END LEFTRAIL -->

									<div id="article">

										<h2>Mrs. Mary Elizabeth &#8220;Bess&#8221; Ross Speer:   Celebration of Life Service Saturday, September 26 at 11:00am</h2>

										<div class="byline">
											
											<a href="https://m.americustimesrecorder.com/author/nichole.buchanan/" rel="bookmark">
                        <img alt='' src='https://secure.gravatar.com/avatar/10b1c686d86de246d684769af51fd213?s=120&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/10b1c686d86de246d684769af51fd213?s=240&#038;d=mm&#038;r=g 2x' class='avatar avatar-120 photo' height='120' width='120' />											</a>

											<p class="author">
												<strong>By <a href="https://m.americustimesrecorder.com/author/nichole.buchanan/" rel="bookmark">Nichole Buchanan</a></strong>
																							</p>
											<p class="social">
												<a class="email" href="mailto:nichole.buchanan@americustimesrecorder.com">Email the author</a>
																							</p>
											<p class="pubStamp">Published 11:48 am Wednesday, September 23, 2020</p>
																						<div class="clearfix"></div>
										</div><!-- END BYLINE -->

                    
                    <div class="one_by_one_group">
											<!-- extra_one_by_one -->
<div id='div-gpt-ad-extra_one_by_one'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one'); });
  </script>
</div>											<!-- extra_one_by_one_two -->
<div id='div-gpt-ad-extra_one_by_one_two'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_one_by_one_two'); });
  </script>
</div>											<!-- extra_oop -->
<div id='div-gpt-ad-extra_oop'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-extra_oop'); });
  </script>
</div>                    </div>

										<div class="p402_premium">


										
										<div class="story_detail">
                      <div class="read_more_wrap">
                        
        <table id="trinity-audio-table" style="width:100%; display: table;">
            <tr>
                <td id="trinity-audio-tab" style="border: none;">
                    <div id="trinity-audio-player-label"></div>
                    <script>var TRINITY_TTS_WP_CONFIG = {"cleanText":"Mrs. Mary Elizabeth \u201cBess\u201d Ross Speer:   Celebration of Life Service Saturday, September 26 at 11:00am. \r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\nMrs. Mary Elizabeth \"Bess\" Ross Speer, age 92, passed away on Tuesday, April 7, 2020 at Perfect Care.\r\n\u00a0\r\nA private burial and committal service was held on Thursday, April 9, at Oak Grove Cemetery with Dr. Bryan Myers officiating.\u00a0 Due to the ongoing COVID-19 emergency, the celebration of life service was postponed and is now scheduled for 11:00 AM on Saturday, September 26, at Central Baptist Church with Dr. Bryan Myers and Rev. Hugh DeLoach officiating.\u00a0 The family will receive friends in the foyer of Central Baptist Church immediately following the service.\u00a0\r\n\u00a0\r\nShe was born July 6, 1927 in Schley County, a daughter of the late James H. Ross, Jr. and the late Mattie Will Powell Ross McLeod.\r\n\u00a0\r\nA longtime member of Central Baptist Church, Mrs. Speer was retired from Sumter Regional Hospital where she was employed for many years as a Registered Nurse. She was a former member of the Ladies Auxiliary of the Railroad, Firemen & Engineers; of the B.P.W. Club, of Beta Sigma Phi; and of the 12th District Nursing Association. She was a graduate of Macon Hospital School of Nursing, where she was a member of the Cadet Nursing Corps for three years during World War II.\r\n\u00a0\r\nIn addition to her parents, she was preceded in death by her husband, Charles R. \"Charlie\" Speer; and by her sister and brother-in-law, Martha Norton and F.D. \"Square\" Norton.\r\n\u00a0\r\nSurvivors include two sons: Charles Russell Speer, Jr. (Judy) of East Bernstadt, KY and James Thompson Speer of Americus; two granddaughters: Kimberly \"Charley\" Speer (Michael) of Marble, CO and Stacey Elizabeth Speer Smithley (Steve) of Yorktown, VA; two great-granddaughters: Cassie Smithley and Brooke Smithley; and several nieces, nephews and cousins.\r\n\u00a0\r\nTo sign our online guestbook and express your condolences to the family, please visit\u00a0www.hancockfuneralhomeinc.com\r\n\u00a0\r\nHancock Funeral Home, 427 S. Lee St., is honored to be entrusted with these arrangements for Mrs. Mary Elizabeth \"Bess\" Ross Speer.\u00a0\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\nAttachments area\r\n\r\n\r\n\r\n\r\n\r\n\r\n\r\n","pluginVersion":"2.4.0"};</script><script type="text/javascript" src="https://trinitymedia.ai/player/trinity.php?viewkey=92493df649a98802c2d7fdd467f40a5d&postHash=0606fa885840beecfbc3d5e11c37db27&language=en-US&voiceGender=m&poweredby=1"></script>
                </td>
            </tr>
        </table><script>console.debug('TRINITY_WP', 'trinity_content_filter');</script><div class="gs">
<div class="">
<div id=":442" class="ii gt">
<div id=":45v" class="a3s aXjCH ">
<blockquote>
<div id="m_-2861448251582789164yiv1588186572">
<div>
<div>
<div><span style="font-size: x-large;">Mrs. Mary Elizabeth &#8220;Bess&#8221; Ross Speer, age 92, passed away on Tuesday, April 7, 2020 at Perfect Care.</span></div>
<div><span style="font-size: x-large;"> </span></div>
<div><span style="font-size: x-large;">A private burial and committal service was held on Thursday, April 9, at Oak Grove Cemetery with Dr. Bryan Myers officiating.  Due to the ongoing COVID-19 emergency, the celebration of life service was postponed and is now scheduled for 11:00 AM on Saturday, September 26, at Central Baptist Church with Dr. Bryan Myers and Rev. Hugh DeLoach officiating.  The family will receive friends in the foyer of Central Baptist Church immediately following the service. </span></div>
<div><span style="font-size: x-large;"> </span></div>
<div><span style="font-size: x-large;">She was born July 6, 1927 in Schley County, a daughter of the late James H. Ross, Jr. and the late Mattie Will Powell Ross McLeod.</span></div>
<div><span style="font-size: x-large;"> </span></div>
<div><span style="font-size: x-large;">A longtime member of Central Baptist Church, Mrs. Speer was retired from Sumter Regional Hospital where she was employed for many years as a Registered Nurse. She was a former member of the Ladies Auxiliary of the Railroad, Firemen &amp; Engineers; of the B.P.W. Club, of Beta Sigma Phi; and of the 12th District Nursing Association. She was a graduate of Macon Hospital School of Nursing, where she was a member of the Cadet Nursing Corps for three years during World War II.</span></div>
<div><span style="font-size: x-large;"> </span></div>
<div><span style="font-size: x-large;">In addition to her parents, she was preceded in death by her husband, Charles R. &#8220;Charlie&#8221; Speer; and by her sister and brother-in-law, Martha Norton and F.D. &#8220;Square&#8221; Norton.</span></div>
<div><span style="font-size: x-large;"> </span></div>
<div><span style="font-size: x-large;">Survivors include two sons: Charles Russell Speer, Jr. (Judy) of East Bernstadt, KY and James Thompson Speer of Americus; two granddaughters: Kimberly &#8220;Charley&#8221; Speer (Michael) of Marble, CO and Stacey Elizabeth Speer Smithley (Steve) of Yorktown, VA; two great-granddaughters: Cassie Smithley and Brooke Smithley; and several nieces, nephews and cousins.</span></div>
<div><span style="font-size: x-large;"> </span></div>
<div><span style="font-size: x-large;">To sign our online guestbook and express your condolences to the family, please visit <a href="http://www.hancockfuneralhomeinc.com/" target="_blank" rel="nofollow noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=http://www.hancockfuneralhomeinc.com/&amp;source=gmail&amp;ust=1600961181918000&amp;usg=AFQjCNH_cqoxOPJzIbFRxcHZegp3qWNw6Q">www.<wbr />hancockfuneralhomeinc.com</a></span></div>
<div><span style="font-size: x-large;"> </span></div>
<div><span style="font-size: x-large;">Hancock Funeral Home, 427 S. Lee St., is honored to be entrusted with these arrangements for Mrs. Mary Elizabeth &#8220;Bess&#8221; Ross Speer. </span></div>
<div class="yj6qo"></div>
<div class="adL"></div>
</div>
<div class="adL"></div>
</div>
<div class="adL"></div>
</div>
</blockquote>
</div>
</div>
<div id=":45t" class="hq gt a10">
<div class="hp"></div>
<div class="a3I">Attachments area</div>
<div id=":45q"></div>
<div id=":45r" class="aQH">
<div class="aZK"></div>
</div>
</div>
<div class="hi"></div>
</div>
</div>

                                              


                      </div>


										</div><!-- END STORY_DETAIL -->
										</div><!-- END p402_premium (GOOGLE SURVEY) -->
										<script type="text/javascript">
											 var load_402_show_function = function () { try { _402_Show(); } catch(e) { } }
										</script>

												

											<div class="articleOptions">
												<div class="admin">
</div>
<div class="clearfix"></div>
											</div>



                      <div id="rc-widget-61eef3" data-rc-widget data-widget-host="habitat" data-endpoint="//trends.revcontent.com" data-widget-id="134050"></div>
        <script type="text/javascript" src="https://assets.revcontent.com/master/delivery.js" defer="defer"></script>
    

	
<div class="one_by_one_group">
<!-- one_by_one_duration-->
<div id='div-gpt-ad-one_by_one_duration'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-one_by_one_duration'); });
  </script>
</div><div id="rev_video"></div>
</div>



												

<div id="disqus_thread"></div>

<script>
    /**
    * RECOMMENDED CONFIGURATION VARIABLES: EDIT AND UNCOMMENT THE SECTION BELOW TO INSERT DYNAMIC VALUES FROM YOUR PLATFORM OR CMS.
    * LEARN WHY DEFINING THESE VARIABLES IS IMPORTANT: https://disqus.com/admin/universalcode/#configuration-variables
    */
    /*
    */
    var disqus_config = function () {
      //this.page.url = 'https://m.americustimesrecorder.com/2020/09/23/mrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am/';
      this.page.identifier = '48705 https://m.americustimesrecorder.com/?p=48705';
      this.page.title = 'Mrs. Mary Elizabeth &quot;Bess&quot; Ross Speer: Celebration of Life Service Saturday, September 26 at 11:00am - Americus Times-Recorder';
    };
    (function() { // DON'T EDIT BELOW THIS LINE
    var d = document, s = d.createElement('script');

    s.src = '//americustimesrecorder.disqus.com/embed.js';

    s.setAttribute('data-timestamp', +new Date());
    (d.head || d.body).appendChild(s);
    })();
</script>
  <noscript>Please enable JavaScript to view the <a href="https://disqus.com/?ref_noscript" rel="nofollow">comments powered by Disqus.</a></noscript>



									</div>
									<div class="clearfix"></div>

								</div>
							</div>
							<div class="col last">
								
<ul class="sidebar">
	<li>
		<div class="ad first">
      <div id='div-gpt-ad-bigblock-4'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-4'); });
  </script>
</div>		</div>
	</li>
	<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-2" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Opinion</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/10/04/leila-case-gatewoods-flower-shop-continues-to-bloom-at-75/" title="Permalink to Leila Case: Gatewood’s Flower Shop continues to bloom at 75" rel="bookmark">Leila Case: Gatewood’s Flower Shop continues to bloom at 75</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/10/04/keith-wishum-doing-the-small-things-is-critical/" title="Permalink to Keith Wishum: Doing the small things is critical" rel="bookmark">Keith Wishum: Doing the small things is critical</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/10/04/our-opinion-national-newspaper-week-commemorates-community-institution/" title="Permalink to Our opinion: National Newspaper Week commemorates community institution" rel="bookmark">Our opinion: National Newspaper Week commemorates community institution</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/10/04/your-opinion-10-5-19/" title="Permalink to Your opinion: 10-5-19" rel="bookmark">Your opinion: 10-5-19</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/10/03/dick-yarbrough-if-you-want-to-talk-impeachment-youd-better-hurry/" title="Permalink to Dick Yarbrough: If you want to talk impeachment, you’d better hurry" rel="bookmark">Dick Yarbrough: If you want to talk impeachment, you’d better hurry</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
		<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-5'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-5'); });
  </script>
</div>		</div>
	</li>

  				<li id="recent-posts-3" class="widget widget_recent_entries">		<h2 class="widgettitle">Recent Posts</h2>
		<ul>
											<li>
					<a href="https://m.americustimesrecorder.com/2020/09/23/mrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am/" aria-current="page">Mrs. Mary Elizabeth &#8220;Bess&#8221; Ross Speer:   Celebration of Life Service Saturday, September 26 at 11:00am</a>
									</li>
											<li>
					<a href="https://m.americustimesrecorder.com/2020/09/23/city-council-holds-lengthy-agenda-setting-meeting/">City Council holds lengthy Agenda Setting meeting</a>
									</li>
											<li>
					<a href="https://m.americustimesrecorder.com/2020/09/22/lady-wildcats-shut-out-marion-county-on-senior-day/">Lady Wildcats shut out Marion County on Senior Day</a>
									</li>
											<li>
					<a href="https://m.americustimesrecorder.com/2020/09/22/south-georgia-tech-hosts-successful-blood-drive/">South Georgia Tech hosts successful blood drive</a>
									</li>
											<li>
					<a href="https://m.americustimesrecorder.com/2020/09/22/lady-wildcats-softball-team-falls-to-crisp-county/">Lady Wildcats’ softball team falls to Crisp County</a>
									</li>
					</ul>
		</li>

	<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-3" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Sports</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/09/22/lady-wildcats-shut-out-marion-county-on-senior-day/" title="Permalink to Lady Wildcats shut out Marion County on Senior Day" rel="bookmark">Lady Wildcats shut out Marion County on Senior Day</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/09/22/lady-wildcats-softball-team-falls-to-crisp-county/" title="Permalink to Lady Wildcats’ softball team falls to Crisp County" rel="bookmark">Lady Wildcats’ softball team falls to Crisp County</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/09/22/wynn-finishes-in-top-five-while-local-middle-and-high-school-xc-teams-place-high-at-dws-meet/" title="Permalink to Wynn finishes in top five while local middle and high school XC teams place high at DWS meet" rel="bookmark">Wynn finishes in top five while local middle and high school XC teams place high at DWS meet</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/09/21/seniors-come-through-for-lady-raiders-on-senior-day/" title="Permalink to Seniors come through for Lady Raiders on Senior Day" rel="bookmark">Seniors come through for Lady Raiders on Senior Day</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/09/21/renfroes-four-yard-rushing-touchdown-in-fourth-quarter-caps-off-comeback-victory-for-schley-county/" title="Permalink to Renfroe’s four-yard rushing touchdown in fourth quarter caps off comeback victory for Schley County" rel="bookmark">Renfroe’s four-yard rushing touchdown in fourth quarter caps off comeback victory for Schley County</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-4" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Lifestyles</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/09/04/wiggins-mitchell/" title="Permalink to Wiggins-Mitchell" rel="bookmark">Wiggins-Mitchell</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/08/23/swain-milledge/" title="Permalink to Swain-Milledge" rel="bookmark">Swain-Milledge</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/06/26/teasley-ledger/" title="Permalink to Teasley-Ledger" rel="bookmark">Teasley-Ledger</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/06/08/leila-case-ahs-alums-have-strong-tie-that-binds/" title="Permalink to Leila Case: AHS alums have strong tie that binds" rel="bookmark">Leila Case: AHS alums have strong tie that binds</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/03/09/wilson-moyd/" title="Permalink to Wilson-Moyd" rel="bookmark">Wilson-Moyd</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-5" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Religion</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/06/19/community-prayer-box-is-ready-to-accept-prayers-at-leslie-united-methodist-church/" title="Permalink to Community prayer box is ready to accept prayers at Leslie United Methodist Church" rel="bookmark">Community prayer box is ready to accept prayers at Leslie United Methodist Church</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/10/04/keith-wishum-doing-the-small-things-is-critical/" title="Permalink to Keith Wishum: Doing the small things is critical" rel="bookmark">Keith Wishum: Doing the small things is critical</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/10/04/church-briefs-10-5-19/" title="Permalink to Church briefs: 10-5-19" rel="bookmark">Church briefs: 10-5-19</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/10/03/local-law-enforcement-officers-blessed-at-st-johns/" title="Permalink to Local law enforcement officers blessed at St. John’s" rel="bookmark">Local law enforcement officers blessed at St. John’s</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2019/09/27/keith-wishum-how-do-we-destroy-our-enemies/" title="Permalink to Keith Wishum: How do we destroy our enemies?" rel="bookmark">Keith Wishum: How do we destroy our enemies?</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
	<li>
		<div class="ad">
      <div id='div-gpt-ad-bigblock-6'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-bigblock-6'); });
  </script>
</div>		</div>
	</li>

	<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-6" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Obits</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/09/23/mrs-mary-elizabeth-bess-ross-speer-celebration-of-life-service-saturday-september-26-at-1100am/" title="Permalink to Mrs. Mary Elizabeth &#8220;Bess&#8221; Ross Speer:   Celebration of Life Service Saturday, September 26 at 11:00am" rel="bookmark">Mrs. Mary Elizabeth &#8220;Bess&#8221; Ross Speer:   Celebration of Life Service Saturday, September 26 at 11:00am</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/09/21/reverend-john-paul-dent-september-18-2020/" title="Permalink to Reverend John Paul Dent:  September 18, 2020" rel="bookmark">Reverend John Paul Dent:  September 18, 2020</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/09/17/tony-davis-september-17-2020/" title="Permalink to Tony Davis:  September 17, 2020" rel="bookmark">Tony Davis:  September 17, 2020</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/09/14/troy-lee-simmons-september-5-2020/" title="Permalink to Troy Lee Simmons: September 5, 2020" rel="bookmark">Troy Lee Simmons: September 5, 2020</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/09/11/carrie-anne-williams-september-8-2020/" title="Permalink to Carrie Anne Williams:  September 8, 2020" rel="bookmark">Carrie Anne Williams:  September 8, 2020</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>
<style>
.rpwe-block ul{list-style:none!important;margin-left:0!important;padding-left:0!important;}.rpwe-block li{border-bottom:1px solid #eee;margin-bottom:10px;padding-bottom:10px;list-style-type: none;}.rpwe-block a{display:inline!important;text-decoration:none;}.rpwe-block h3{background:none!important;clear:none;margin-bottom:0!important;margin-top:0!important;font-weight:400;font-size:12px!important;line-height:1.5em;}.rpwe-thumb{border:1px solid #EEE!important;box-shadow:none!important;margin:2px 10px 2px 0;padding:3px!important;}.rpwe-summary{font-size:12px;}.rpwe-time{color:#bbb;font-size:11px;}.rpwe-comment{color:#bbb;font-size:11px;padding-left:5px;}.rpwe-alignleft{display:inline;float:left;}.rpwe-alignright{display:inline;float:right;}.rpwe-aligncenter{display:block;margin-left: auto;margin-right: auto;}.rpwe-clearfix:before,.rpwe-clearfix:after{content:"";display:table !important;}.rpwe-clearfix:after{clear:both;}.rpwe-clearfix{zoom:1;}
</style>
	<li id="rpwe_widget-7" class="widget rpwe_widget recent-posts-extended"><h2 class="widgettitle">Latest Public Records</h2>
<div  class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/08/26/furlow-charter-school-called-meeting-3/" title="Permalink to Furlow Charter School called meeting" rel="bookmark">Furlow Charter School called meeting</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/08/05/public-notice-3/" title="Permalink to Public Notice" rel="bookmark">Public Notice</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/07/20/furlow-charter-school-executive-committee-called-meeting/" title="Permalink to Furlow Charter School Executive Committee Called Meeting" rel="bookmark">Furlow Charter School Executive Committee Called Meeting</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/07/06/sumter-county-board-of-education-meeting-7-7-20/" title="Permalink to Sumter County Board of Education Meeting 7/7/20" rel="bookmark">Sumter County Board of Education Meeting 7/7/20</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://m.americustimesrecorder.com/2020/07/01/city-of-plains-adopted-budget-july-12020-june-30-2021/" title="Permalink to City of Plains Adopted Budget July 1,2020 &#8211; June 30, 2021" rel="bookmark">City of Plains Adopted Budget July 1,2020 &#8211; June 30, 2021</a></h3></li></ul></div><!-- Generated by http://wordpress.org/plugins/recent-posts-widget-extended/ --></li>

	<li>
		<div class="ad">
			<div id='div-gpt-ad-halfpage-1'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-halfpage-1'); });
  </script>
</div>		</div>
	</li>
  </ul>							</div>

							<div id="flow_news">
								<div id="flow_news_slider">
									<div class="wrap ca-wrapper">
																				<div class="story ca-item">
											<h4 class="category">News Main</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/23/city-council-holds-lengthy-agenda-setting-meeting/" rel="bookmark" title="City Council holds lengthy Agenda Setting meeting">City Council holds lengthy Agenda Setting meeting</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/22/south-georgia-tech-hosts-successful-blood-drive/" rel="bookmark" title="South Georgia Tech hosts successful blood drive">South Georgia Tech hosts successful blood drive</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/20/candidates-vying-to-represent-state-house-of-representatives-district-138-make-their-cases-at-americus-kiwanis-club-forum/" rel="bookmark" title="Candidates vying to represent Georgia House of Representatives District 138 make their case at Americus Kiwanis Club forum">Candidates vying to represent Georgia House of Representatives District 138 make their case at Americus Kiwanis Club forum</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">News Main</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/18/drug-trafficking-arrest-by-americus-police-department/" rel="bookmark" title="Drug Trafficking arrest by Americus Police Department">Drug Trafficking arrest by Americus Police Department</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/16/sumter-county-board-of-commissioners-approves-revised-bid-evaluation-procedures/" rel="bookmark" title="Sumter County Board of Commissioners approves revised bid evaluation procedures">Sumter County Board of Commissioners approves revised bid evaluation procedures</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">education</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/11/sumter-county-board-of-education-votes-to-continue-virtual-learning-another-9-weeks/" rel="bookmark" title="Sumter County Board of Education votes to continue virtual learning another 9 weeks">Sumter County Board of Education votes to continue virtual learning another 9 weeks</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">education</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/10/georgia-identifies-tests-to-be-eliminated-in-response-to-sb-367-aligning-state-testing-requirements-to-the-federal-minimum/" rel="bookmark" title="Georgia identifies tests to be eliminated in response to SB 367, aligning state testing requirements to the federal minimum">Georgia identifies tests to be eliminated in response to SB 367, aligning state testing requirements to the federal minimum</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/09/county-board-of-commissioners-not-happy-with-soweag-fair-being-in-americus/" rel="bookmark" title="County Board of Commissioners not happy with SOWEAG Fair being in Americus">County Board of Commissioners not happy with SOWEAG Fair being in Americus</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/05/candidates-for-sumter-county-sherriff-make-their-cases-at-kiwanis-club-meeting/" rel="bookmark" title="Candidates for Sumter County Sheriff make their cases at Kiwanis Club meeting">Candidates for Sumter County Sheriff make their cases at Kiwanis Club meeting</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local news</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/03/jimmy-davis-recognized-for-service-as-chair-of-sgtc-board-of-directors/" rel="bookmark" title="Jimmy Davis recognized for service as Chair of SGTC Board of Directors">Jimmy Davis recognized for service as Chair of SGTC Board of Directors</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local news</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/03/sgtc-career-services-conducts-resume-workshop-for-electrical-line-worker-class/" rel="bookmark" title="SGTC Career Services conducts resume workshop for electrical line worker class">SGTC Career Services conducts resume workshop for electrical line worker class</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/03/sc-board-of-elections-decides-to-uphold-earlier-decision-to-disqualify-dr-michael-busman-from-running-for-district-6-seat/" rel="bookmark" title="SC Board of Elections decides to uphold earlier decision to disqualify Dr. Michael Busman from running for District 6 seat">SC Board of Elections decides to uphold earlier decision to disqualify Dr. Michael Busman from running for District 6 seat</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local news</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/02/cafe-campesino-opens-shop-on-georgia-southwesterns-campus/" rel="bookmark" title="Cafe Campesino opens shop on Georgia Southwestern&#8217;s campus">Cafe Campesino opens shop on Georgia Southwestern&#8217;s campus</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">BREAKING NEWS</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/02/sowega-fair-to-be-held-in-americus/" rel="bookmark" title="SOWEGA Fair to be Held in Americus">SOWEGA Fair to be Held in Americus</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local news</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/09/01/south-georgia-tech-to-conduct-webinars-for-students/" rel="bookmark" title="South Georgia Tech to conduct webinars for students">South Georgia Tech to conduct webinars for students</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/08/30/southland-academy-head-football-coach-rod-murray-addresses-americus-kiwanis-club/" rel="bookmark" title="Southland Academy Head Football Coach Rod Murray addresses Americus Kiwanis Club">Southland Academy Head Football Coach Rod Murray addresses Americus Kiwanis Club</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/08/27/south-georgia-tech-releases-presidents-list-for-2020-summer-semester/" rel="bookmark" title="South Georgia Tech releases President’s List for 2020 Summer Semester">South Georgia Tech releases President’s List for 2020 Summer Semester</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">DEVELOPING NEWS</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/08/27/qualified-candidates-for-the-sumter-county-school-board-election/" rel="bookmark" title="Qualified candidates for the Sumter County School Board election">Qualified candidates for the Sumter County School Board election</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">education</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/08/26/furlow-charter-school-called-meeting-3/" rel="bookmark" title="Furlow Charter School called meeting">Furlow Charter School called meeting</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/08/24/south-georgia-tech-to-host-financial-aid-workshop-on-americus-campus/" rel="bookmark" title="South Georgia Tech to Host Financial Aid Workshop on Americus Campus">South Georgia Tech to Host Financial Aid Workshop on Americus Campus</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/08/24/gsw-college-of-business-and-computing-renews-prestigious-aacsb-business-accreditation/" rel="bookmark" title="GSW College of Business and Computing renews prestigious AACSB Business Accreditation">GSW College of Business and Computing renews prestigious AACSB Business Accreditation</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/08/21/phoebe-reports-friday-covid-19-numbers/" rel="bookmark" title="Phoebe reports Friday COVID-19 numbers">Phoebe reports Friday COVID-19 numbers</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/08/19/sgtc-conducts-log-truck-driver-safety-training-program/" rel="bookmark" title="SGTC conducts Log Truck Driver Safety training program">SGTC conducts Log Truck Driver Safety training program</a></h3>
										</div><!-- END STORY -->
																				<div class="story ca-item">
											<h4 class="category">Local News</h4>
											<h3><a href="https://m.americustimesrecorder.com/2020/08/19/south-georgia-techs-mclain-center-suffers-water-damage/" rel="bookmark" title="South Georgia Tech’s McLain Center suffers water damage">South Georgia Tech’s McLain Center suffers water damage</a></h3>
										</div><!-- END STORY -->
																			</div>
								</div>
							</div>

						<div class="clearfix"></div>
					</div>
					<div id="footer" class="clearfix">

						<div id="footSections" class="col">
														<h4>Sections</h4>
							<ol class="siteMap">
								<li><a href="https://m.americustimesrecorder.com" rel="bookmark"><span>Home</span></a></li>
								<li><a href="https://m.americustimesrecorder.com/category/news/"  title="" rel="bookmark"><span>News</span></a></li>
								<li><a href="https://m.americustimesrecorder.com/category/sports/" title="" rel="bookmark"><span>Sports</span></a></li>
								<li><a href="https://m.americustimesrecorder.com/category/opinion/" title="" rel="bookmark"><span>Opinion</span></a></li>
								<li><a href="https://m.americustimesrecorder.com/category/obituaries/">Obits</a></li>
								<li><a href="https://m.americustimesrecorder.com/category/lifestyles/">Lifestyles</a>
								<li><a href="https://m.americustimesrecorder.com/category/religion/">Religion</a></li>
								<li><a href="https://marketplace.americustimesrecorder.com/AdHunter/americus">Classifieds</a></li>
							</ol>
						</div>


						<div id="footServices" class="col">
														<h4>Services</h4>
							<ol class="siteMap">
								<li class=""><a href="https://m.americustimesrecorder.com/services/about-us/">About Us</a></li>
								<li><a href="https://m.americustimesrecorder.com/services/policies/" title="" rel="bookmark">Policies</a></li>
								<li><a href="https://m.americustimesrecorder.com/services/policies/#termsofuse" title="" rel="bookmark">Terms of Use</a></li>
								<li class=""><a href="https://m.americustimesrecorder.com/subscriptions/">Subscribe</a></li>
								<li class=""><a href="https://m.americustimesrecorder.com/submit/">Submit</a></li>
												
								
															</ol>
						</div>


						<div id="footCopyright" class="col">
							


							<h4>Copyright</h4>
							<ol>
								<li>&copy; 2020, Americus Times-Recorder</li>
							</ol>
						</div>

					</div>
				</div>

        <div id="mobile_footer_ad">
					<div class="ad">
						<!-- 320x50_mobile_sticky -->
<div id='div-gpt-ad-mobile-sticky'>
  <script>
    googletag.cmd.push(function() { googletag.display('div-gpt-ad-mobile-sticky'); });
  </script>
</div>					</div>
				</div>

				</div>

				<div class="sb-slidebar sb-left">
					<!-- Your left Slidebar content. -->
					<ul id="slidebarList">
					</ul>
				</div>


								<script src="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/slidebars/slidebars.js?1583853197"></script>
        <script src="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.bxslider/jquery.bxslider.min.js"></script>
        <script src="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.contentcarousel.js"></script>
        <script src="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.easing.1.3.js"></script>
				<script src="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/js/vendor/jquery.timeago.js"></script>
				<script src="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/js/vendor/readmore.min.js"></script>
        <script src="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/js/plugins.js?1583853197"></script>
        <script src="https://www.americustimesrecorder.com/wp-content/themes/2016-bni-mobile/media/js/main.js?1583853197"></script>

        

	
				
<script type="text/javascript">tb_pathToImage = "https://m.americustimesrecorder.com/wp-includes/js/thickbox/loadingAnimation.gif";tb_closeImage = "https://m.americustimesrecorder.com/wp-includes/js/thickbox/tb-close.png";</script>
<script>
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"https:\/\/m.americustimesrecorder.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
</script>
<script type='text/javascript' src='https://m.americustimesrecorder.com/wp-includes/js/thickbox/thickbox.js?m=1591831625g'></script>
<script src='https://www.americustimesrecorder.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.3.6'></script>
<script>
var pollsL10n = {"ajax_url":"https:\/\/m.americustimesrecorder.com\/wp-admin\/admin-ajax.php","text_wait":"Your last request is still being processed. Please wait a while ...","text_valid":"Please choose a valid poll answer.","text_multiple":"Maximum number of choices allowed: ","show_loading":"1","show_fading":"1"};
</script>
<script src='https://www.americustimesrecorder.com/wp-content/plugins/wp-polls/polls-js.js?ver=2.75.3'></script>
<script type='text/javascript' src='https://m.americustimesrecorder.com/wp-includes/js/wp-embed.min.js?m=1591831626g'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202039.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9.1',blog:'175848658',post:'48705',tz:'-4',srv:'m.americustimesrecorder.com'} ]);
	_stq.push([ 'clickTrackerInit', '175848658', '48705' ]);
</script>
				</div><!-- END undertone -->
        				<script id="dsq-count-scr" src="//americustimesrecorder.disqus.com/count.js" async></script>
            </body>
</html>